LMS/LCMS More Puzzlers – OS + Language + Browsers

eLearning 24-7

I realized I left out three additional gems that vendors seem to have just fallen off the planet when it comes to the REAL WORLD! They are not going away, and yet an enormous amount of vendors do not support them, let alone Safari. Apparently they are awash in cash or assume that everyone uses Microsoft. Microsoft – Windows 7. And yes, Firefox supports 64 bit. Many vendors support this. Firefox 3.0+. Microsoft IE. E-Learning 24/7.

LCMS 40

HTML5 – Let the Games Begin!

eLearning 24-7

Every month, I will providing an emerging technology that I believe will be a game changer in the e-learning industry. I call it ELGC (E-learning game changer). Improves video and audio quality – extensively – thus your Social Learning/Social Media experience has just increased infinitely; Vivemo, Blip.tv Works in the Ipad Tablet and will work in other manufacture tablets, smartphones too – M-Learning to the next level. Firefox 4.0

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

HTML5 – Let the Games Begin!

eLearning 24-7

Every month, I will providing an emerging technology that I believe will be a game changer in the e-learning industry. I call it ELGC (E-learning game changer). Improves video and audio quality – extensively – thus your Social Learning/Social Media experience has just increased infinitely; Vivemo, Blip.tv Works in the Ipad Tablet and will work in other manufacture tablets, smartphones too – M-Learning to the next level. Firefox 4.0

Something is Going on Down there in the LMS Market

eLearning 24-7

LMS Vendors and Tablets Update. That said, why is this happening: A significant (over 90%) of vendors are holding off this year and at least part of next year from optimizing their solution to the iPad. But with LMS vendors jumping into the mobile learning sector, at least in some cases, it may be a tad misleading, especially with smartphones. I’m sure they tested with IE, Firefox, Safari and Chrome, but what about Opera Mini? Firefox 4.0